RISELab实验室正在开发的Ray项目初步尝试记录

Ray是RISELab实验室在开发的一个项目,目前还没有发布(20170208,20170124就听说了),想试下,听说架构和性能都有很大提升。

之前学的Spark就是RISELab的前生,AMPlab开发的。

sudo apt-get update报错了:

Err http://archive.ubuntukylin.com:10006 trusty Release.gpg
  Unable to connect to archive.ubuntukylin.com:10006:
Reading package lists... Done
W: Failed to fetch http://archive.ubuntukylin.com:10006/ubuntukylin/dists/trusty/InRelease  

W: Failed to fetch http://ppa.launchpad.net/natecarlson/maven3/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/natecarlson/maven3/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found

W: Failed to fetch http://archive.ubuntukylin.com:10006/ubuntukylin/dists/trusty/Release.gpg  Unable to connect to archive.ubuntukylin.com:10006:

W: Some index files failed to download. They have been ignored, or old ones used instead.

安装依赖的时候也报错了:

xubo@xubo:~/cloud$ sudo apt-get install -y cmake build-essential autoconf curl libtool libboost-all-dev unzip python-dev python-pip  # If you're using Anaconda, then python-dev and python-pip are unnecessary.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
autoconf is already the newest version.
libtool is already the newest version.
curl is already the newest version.
curl set to manually installed.
unzip is already the newest version.
unzip set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 build-essential : Depends: dpkg-dev (>= 1.13.5) but it is not going to be installed
 libboost-all-dev : Depends: libboost-date-time-dev but it is not going to be installed
                    Depends: libboost-filesystem-dev but it is not going to be installed
                    Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-log-dev but it is not going to be installed
                    Depends: libboost-mpi-dev but it is not going to be installed
                    Depends: libboost-mpi-python-dev but it is not going to be installed
                    Depends: libboost-program-options-dev but it is not going to be installed
                    Depends: libboost-python-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
                    Depends: libboost-system-dev but it is not going to be installed
                    Depends: libboost-thread-dev but it is not going to be installed
                    Depends: libboost-wave-dev but it is not going to be installed
 python-dev : Depends: libpython-dev (= 2.7.5-5ubuntu3) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.5-1~) but it is not going to be installed
 python-pip : Depends: python-setuptools (>= 0.6c1) but it is not going to be installed
              Recommends: python-dev-all (>= 2.6) but it is not installable
E: Unable to correct problems, you have held broken packages.

分析:ubuntu源有问题,有时间在弄,先忙毕业。

【1】https://github.com/ray-project/ray
【2】https://github.com/ray-project/ray/blob/master/doc/install-on-ubuntu.md

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页